如何利用macd选股,如何通过分析软件利用MACD条件选股?

  Q1:如何通过分析软件利用MACD条件选股?

DIFF := EMA(CLOSE,S) - EMA(CLOSE,P);
DEA := EMA(DIFF,M);
MACD := 2*(DIFF-DEA);
buy:cross(macd,dea) and dea>ref(dea,1);
将这个作为选股公式保存。
参数P缺省26 S12 M9

  Q2:如何运用MACD选股

MACD(平滑异同移动平均线12-26-9):
上穿0轴技巧:当DIFF由下往上穿越0轴的时候,表明一个多头市场的扬升即将开始,上穿0轴后,应该在它回调5日平均线的时候逢低吸纳。
拒绝死叉技巧:DIFF与DEA即将死叉的时候反身向上运行,股价必然会向上,价格一般会至少到前期头部。
空中加油技巧:DIFF与DEA金叉后,运行了一段时间会逐步走上0轴,主力也会选择适当时机洗盘,这时往往会出现DIFF指标线向下死叉DEA的情况,而这个时候我们应该观察平均线的变化,当它在重要的平均线收到支撑时,DIFF就会在0轴以上再次金叉DEA,而这个时候,我们应该介入,一般会有拉升出现。
周线用法:金叉形成后,回抽5周平均线时坚决入场,而卖出点的选择应该是当股价远离5日平均线,并且MACD指标红柱开始缩短的时候,注意买看周线,卖看日线。
缺陷:MACD是一个中线指标,当行情出现忽上忽下和反复盘整的走势时,该指标会出现频繁变化,所以当行情出现盘整和变化不大的时候,尽量避免使用。

  Q3:如何使用MACD选股?

MACD指标简单有效,实际操作中很多股民喜欢运用此指标捕抓强势个股和逃顶抄底。MACD柱线由绿转红(由0轴下方升至0轴上方),意味着由空方主导转为多方主导,股价仍有上升空间,投资者应持股待涨。
精选策略:【DIFF在0轴上方,MACD出叉,成交量放量】

  Q4:如何利用MACD提前选股

MACD指标中的MACD柱线可以表示股价涨跌的内在动力。位于零轴上方的MACD红色柱线越长,说明股价上涨动能越强。位于零轴下方的MACD绿色柱线越长,说明股价的下跌动能越强。当股价在持续下跌过程中连创新低的同时,如果其MACD柱线没有创出新低,反而出现了一底比一底高的上涨形态,二者就形成了底背离形态。MACD柱线和股价底背离形态说明虽然股价还在下跌过程中,但是其内在的下跌动能已经越来越弱,未来股价有见底反弹的可能。
第一买点:第二次底背离完成
当MACD柱线和股价连续两次底背离完成后,说明市场上的下跌动能已经很弱。此时投资者可以先试探性地少量买入股票,逐步建仓。
第二买点:股价突破前期高点
如果未来股价见底反弹,突破前期高点,说明上涨行情已经开始,此时投资者可以积极加仓买入,完成建仓。
止损位:股价再创新低
如果买入股价后,投资者可以将止损位设定在前期股价下跌的最低点位置。如果股价跌破了这个价位,说明下跌行情仍在继续。此时投资者应该卖出手中的股票止损。
操作要点:
1、MACD柱线的底背离形态往往会先于DEA曲线的底背离出现,按照MACD指标的底背离形态,投资者可以更早地抄底买入股票,但也需要更加重视对风险的控制。
2、如果在MACD柱线和股价底背离的同时成交量逐渐萎缩,未来股价见底反弹时成交量逐渐放大,说明空方力量衰退,多方力量增强。该形态的看涨信号会更加可靠。
这些可以慢慢去领悟,在股市中没有百分之百的成功战术,只有合理的分析。每个方法技巧都有应用的环境,也有失败的可能。新手在把握不准的情况下不防用个牛股宝手机炒股去跟着牛人榜里的牛人去操作,这样稳妥得多,希望可以帮助到您,祝投资愉快!

  Q5:如何编写一个以MACD的选股条件来选股

REF(MACD.MACD,1)=LLV(MACD.MACD,10) AND MACD.MACD>REF(MACD.MACD,1)
AND MACD.MACD<0;

  Q6:MACD选股

DIFF:EMA(CLOSE,12)-EMA(CLOSE,27);
DEA:EMA(DIFF,9);
MACD:2*(DIFF-DEA), COLORSTICK,LINICK2;
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
STICKLINE(低位金叉,0,0.08,6,0),COLORYELLOW;
DRAWTEXT(低位金叉,0.16,' 低位金叉'),COLORWHITE;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,0.06,6,0),COLORFF00FF;
DRAWICON(二次金叉,DEA*0.9,1) ;
DRAWTEXT(二次金叉,0.2,' 二次金叉'),COLORYELLOW;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;
底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINICK4;
DRAWTEXT(底背离,0.12,' 底背离'),COLORFF00FF;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINICK4;
DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,0.25,'三全项'),COLOR0000FF,LINICK2;